Application not showing up in Enonic Applications interface

Enonic version: Enonic XP 6.0.0
OS: OSX Yosemite

I’ve followed the instructions for creating and deploying an application to Enonic XP 6.0.0 as explained at

However the app doesn’t show up in the admin console at http://localhost:8080/admin#/applications as expected. The JAR file is in $XP_HOME/deploy - but it seems like the CMS doent’t take notice.

What might be wrong?

Got it. $XP_HOME wasn’t updated after the 5 > 6 upgrade :smile:

Hello Helge,

I tried calling you. Anyways, a few things can be wrong now:

  1. The XP_HOME variable needs to be set to the /home folder, so something like this:

  2. The “gradlew deploy” command didn’t finish correctly. Double check this. Also make sure if you’re using multiple windows/tabs that all can access the XP_HOME variable (it needs to be set in each tab in Terminal).

  3. After gradle deploy succeeds, double check the tab running the XP server that it actually detected the uploaded and changed file. If not, you most likely have a problem with the XP_HOME variable.

Also, try avoiding any spaces in any file path, there’s been reports on that being a trouble sometimes.

Best regards,

Thanks a bunch, Bobby!! :slight_smile:

Ah, there you go =) Problem solved