Snapshotter complains about "java.lang.NoClassDefFoundError: com/enonic/xp/mail/MailMessage"

Enonic version: 6.8.1
OS: Ubuntu 16.04 LTS

On this XP version, I tried to install the Snapshotter application. It was not listed inside the XP admin gui. So I installed it using command line “./ install-app -a su:password -u”.

Then I added the “” configuration.

When the app Snapshotter is started, I get the error:

11:32:52.810 ERROR - BundleComponentActivator : Bundle [85] Unexpected failure enabling component holder
java.lang.NoClassDefFoundError: com/enonic/xp/mail/MailMessage
at java.lang.Class.getDeclaredMethods0(Native Method) ~[na:1.8.0_111]
at java.lang.Class.privateGetDeclaredMethods( ~[na:1.8.0_111]
at java.lang.Class.getDeclaredMethods( ~[na:1.8.0_111]
at org.apache.felix.scr.impl.helper.BindMethod.getServiceObjectAssignableMethod( ~[org.apache.felix.scr-2.0.2.jar:na]
at org.apache.felix.scr.impl.helper.BindMethod.doFindMethod( ~[org.apache.felix.scr-2.0.2.jar:na]
at org.apache.felix.scr.impl.helper.BaseMethod.findMethod( ~[org.apache.felix.scr-2.0.2.jar:na]
at org.apache.felix.scr.impl.helper.BaseMethod.access

I do have “com.enonic.xp.mail.cfg” correctly set up.

Any ideas why the Snapshotter complains about “java.lang.NoClassDefFoundError: com/enonic/xp/mail/MailMessage”?

I did the same setup on an XP 6.13.1 server and it worked fine.


Snapshotter 1.0.5 needs at least version 6.10 of XP, as mentioned in the release log here: The reason why it wasn’t listed in XP admin is exactly that - your version of XP is incompatible with the application.

1 Like

Thanks. I was afraid of that.

This topic was automatically closed after 24 hours. New replies are no longer allowed.