A content type is not showing in admin "Content Types" left menu. What to check?

I have a content type that doesn’t show in Content Types filter in admin. I have tried running reindex.sh script.
the content type is showing up in:

But does not display in the menu.
What are the troubleshooting steps?
Is it the buckets in elasticsearch?
Can I access elasticsearch with http :9200 to see if the data is tagged correctly?

Hi… The content types are not index themselves - they are simply loaded into memory when starting the modules. Where are you missing it? You actually have to create a site for the content type to appear in the content manager app…

Is there a setting similar to:
cms.elasticsearch.http.enabled = true
from 4.7 in XP?
It might be that the mapping have changed and there are errors when reindexing.
Would be good to be able to check it in elastic search manually.

Yes but they are listed in the response:
still it doesn’t show up in the buckets.
Isn’t content in elastic marked with _type fields?
I ran reindex.sh with aditional -i to rebuild the index mappings but it didn’t help…
Would be nice to get a starting point, where to look.

WOW! I just deleted the Superhero module + content from repo + ran reindex.sh -i and now it works.
The content type was named Person, coud there be a conflict?

Hi, how many content-types do you have? I think the result is limited to 15 atm in the admin view (note to @tsi about how to handle more that this in gui)

You can check the result of the query with developer-tools or something for requests for http://localhost:8080/admin/rest/content/query

There should be no reason for the mapping to be updated or reindex. In general reindex should almost never be necessary :smile:

OH! Could you please add a scrollbar or just make the Content Types searchable or… add a show all button?
I used a lot of time thinking that the content is not indexed, just because of a display limit on a list? ah… bummer!

In the meantime, is there any querry language to do the filtering manually (without hacking the admin and running own rest calls) for the search field?
Like elastic search querry:
_type=Person first-name=Ole

Is this problem in The “new content dialogue”?

This is the left hand side content filter by content type in admin. A hardcoded 15 item limit is really confusing, any type of pagination or scrolling would help. Would be good if this menu was contextual and enabled filtering only of the selected folder/node.

Also the “select all” does only apply to the loaded elements into admin, if someone would like to delete all elements of a particular type in a folder, or move them, they have to scroll with lazy loading until everything is in the browser to initiate a command… So I think that selecting a folder, then applying a filter to find the desired objects would be a much faster workflow + having the option to select all objects with a filter to initiate a command on the server. So the user would define the filter, define the operation and send it as arguments so the operation can run on the server side. I have been a core java developer on a CMS project so I know that big sites demand solutions to such problems :blush: