Annoying error - how to eliminate?

In the Log Browser, we have an annoying error that repeats itself. It’s not crucial, but it causes noise in the logging, and I would like to remove it. Clearly something is being referenced that can no longer be found - but where? Han how do I remedy it, in Content Studio?

2023-12-27 12:10:49,835 WARN c.e.x.p.i.rendering.FragmentRenderer - Fragment content could not be found. ContentId: 47afc315-d117-4aed-875e-e01b53299219

-So some fragment is gone, yes, and this message is repeated endlessly, but I do not know where it triggers… any way to find out?

Hello @toredahl, you can try installing Data Toolbox app and use search there to find which content and which component of it references missing fragment.
You will need to adjust search filter a bit:
and to empty Query field.

It might look like this:

If that doesn’t help, we will try to find other options

Hi Tore.

Yes, there are several ways to do this.

  1. Check if the fragment still exists. Maybe it has been unpublished or archived. Search using the id
  2. If it does not exist, identify the pages referencing it by a) searching for id in the _references field, or b) by searching for the id in the specific property in the fragment component. Something like this: components.fragment.content

Thank you, both these methods worked.

It seems that it had the property “Publishing Expired” - which apparently results in errors in the log, that is perhaps not necessary? I mean, it does exist, so why does the logger report " Fragment content could not be found."?

I should of course have searched for the id to begin with. I suspected it had been deleted, but that wasn’t the case.

I tried changing status from Expired to Unpublished, but the logger still reports the error. I don’t want to delete it either.

I assume this is logged because you have a published page referencing the item. Solution is to a) edit this page and remove the fragment, or b) publish the fragment.

I guess one can discuss if we should be logging this at all…