Can not access published site

Enonic version: XP 6.0.0
OS: Ubuntu


I cant seem to access the published site on my server. This is not a problem locally.
The preview url for the site is
As far as I know this makes the published url
The link works when logged in to the admin console, but not for anonymous users. You will probably see the same message but I have attached it here as well:

I have given Anonymous read access to the site with “override child permissions”. See image:

Are there any obvious thing I have forgotten about?

This is the same setup as I have locally.

Hi Harald,

When I tested you’re url I also got 404 not found. This is because I think MASTER is using XP_HOME/config/com.enonic.xp.web.vhost.cfg file to look up a hostname to use for the site. MASTER = PRODUCTION

So if you’re <XP_HOME>/config/com.enonic.xp.web.vhost.cfg looks something like this:

enabled = true = xp.harald,io
mapping.harald.source = / = /portal/master/link-child-foundation

the MASTER URL should be sometihing like: http://xp.harald,io and its mapped to youre sitename .

Remember to PUBLISH the site and add the url to you’re hosts file.

Did you remember to actually publish?
Also - use everyone for read access, not anonymous - AS anonymous does not apply to logged-in users!

1 Like

Yeah, I remembered to publish but I did not use “everyone”, but “anonymous”. -_-
I will remember to read the docs well next time! :blush:

Updating from anonymous to everyone at site level with “override child permissions” (and then have it inherit down) did not work as smooth as expected.
It did not take effect until I for every second level item went in edit mode, pressed “edit permissions” and the apply, save draft and then published.


We’ll look into the permissions overwrite issue…

Thx for the tip Harald. I had the same problem on a Site now. Couldn’t figure out why it didn’t respond, only with a 404. The “Everyone”-user was set on all Content and it was publish. This is displayed in Admin.

But I had to go into my Template folder and do what you said (Edit Permissions) to even get my website to display. After that my menu was empty, so had to do the same thing on all of the contents too.