Content is not shown in Content Studio via VPN connection

Enonic version: 7.9.2
OS: Ubuntu

Hello Enonic guys,
I updated XP version from 7.8.1 to the last version 7.9.2. Together with the XP I also updated the Content Studio from 4.0.1 to 4.1.1.
Suddenly there is an error message appeared in the XP - “Lost connection to server - Please wait until connection is restored”, when I connect to the server via VPN. (The server is running in the company, but sometimes I need to connect it from home). This message was never shown in my previous using version (7.8.1).
Even more it’s not possible to see and edit any content, there is only empty page. The server says ERROR 418. I’m using HTTPS connection.

Then I tried to downgrade the XP to 7.8.2 with the same result - the error message appears too.
What has been changed? How can I fix it?
There is the log file of XP and my host config file
XP log file

thank you for help

How are you downgrading from XP 7.9.2 to 7.8.2? Can you describe the steps you’ve taken?

In order to properly downgrade, you need to stop the server, delete the contents inside $XP_HOME/index/, start XP, and then either restore a snapshot from XP 7.8.x or load a dump from XP 7.8.x

XP 7.8.x works best with Content Studio 4.0.2, but also works with Content Studio 4.0.3-4.0.4
XP 7.9.x requires Content Studio 4.1.0 or later.

Are you only experiencing the error when connecting via VPN, and not when you connect without VPN?

Hello bhj

thank you for response. We have 2 environments - staging - production. Staging is for testing and preparation of the new features. The 2 environments run on different VM. All (XP, client app - angular, services) are running in dockers.
XP docker
I have gitlab-ci file for building and staring XP server in docker. Inside the gitlab-ci is variable with the XP version. The file builds the XP docker image according to the Dockerfile. Here is all file structure including the scripts used by the Dockerfile - I think, I got them somewhere from you (Enonic). The docker image is then started by docker-compose file.

If I upgrade / downgrade XP I just change the parameter XP_VERSION in gitlab-ci file. Then I build the image and start it. So the XP server runs from the scratch, just the volumes are permanent.

The problem was, that we used XP 7.8.1-2, with the Content studio 4.0.2 - but it was buggy. See here. So I decided to upgrade the XP (7.9.2) when it was available :-). Then I realized the problem with connection in Staging so I downgrade the version of XP to 7.8.5, 7.8.2. then I upgraded back to 7.9.2.

Now there is running 7.9.2. version. Today morning I found out the connection problem remains even without VPN luckily just on the Staging. Unfortunately I haven’t created data dump!!
What do you recommend?

Hi bhj

good news. The problem was only in my browser. When I clean the browser history data, everything started to work as expected!! Unbelievable :slight_smile: The problem is solved.
Thank you for your time.

1 Like