Deploying my app to 6.3 RC1, none of the content types available?

I made an enonic “app” a while back when 6.0 was fresh. I was going to deploy it on 6.3 RC1 now and see how it worked there. I have modified the build.gradle file so it references the 6.3.0-RC1 version of the gradle plugin and changed xpVersion to ‘6.3.0-RC1’.

After I run gradlew deploy the app gets built successfully and copied to the deploy folder in XP_HOME like it should, the app appears in the Applications bit with a few content types I have included in the project listed as I expected they should be.

The problem is that those content types doesn’t appear in list of available content types when I try to create new content. Have I skip a step that enabled the content types or something? Should the content types listed under Schemas be available immediately as long as the app is “started” ?

Two things I would try immediately:

  1. compare your with one created by the for 6.2/6.3 (or compare it with a recently updated app in the Enonic GitHub repo)
  2. run “gradle clean deploy”

Also caching in the browser might mess this up sometimes. The App Manager finds the contenttypes, but not the Content Manager.

Did you create a site? Content types will only be available under the sites where the app has been added…

This is what the content looks like at the moment:

Did you add the App to this Site? (double click the site)

I knew there probably was something obvious I was missing, haha. It is behaving as expected now, thanks :slight_smile: