Drag and drop in Content Studio is not working properly

**Enonic version:7.13.3

We are having issues with drag and drop Content Studio 5.0.5 and 5.1.*
If you try to move a part from one place to another in the visual part of edit mode in Content Studio; the part you tried to move disappears from the view.

It is also not possible to drag and drop a new part from the right side to the visual part of the page in edit mode. It is simply not possible to do.

There are also quit of bit of js errors in the console, so that might have something to do with it.

Is this an known issue? The editors here are a bit frustrated as they can’t work the way they are used to and are hoping for a fix :slight_smile:


Geir Marius

AFAIK page editor is working nicely for other customers and installations. So, this must be specific to your setup/code.

I propose that you create a support ticket so we can investigate the issue for you specifically!

This would be the reason, yes. You have to look closely at what errors you are getting. For example, if your page is using external scripts then these might be blocked by Content Security Policy.

This is the errors we are getting. This seems to be generated by Content Studio. This used to work before we updated to Content Stuido 5.

I assume you have also upgraded XP to 7.13.x, not just Content Studio?

If so, then the errors you are getting might be caused by empty regions, as described in the XP 7.13 upgrade notes.

Try to modify com.enonic.xp.content.cfg by adding the following line to it:

resolveEmptyRegions = true

and see if that will make a difference.

Yes, we are using XP 7.13.3. I’ll try that config entry locally and see if it resolves things. If it does I’ll create a ticket to get that config entry on our servers.

This seems to make no difference. I still get the same errors as above. I also disabled CSP locally for content studio so nothing here is being blocked either.



I’m not really sure what is going on here.

After some digging around it seems that one of the developers here is the culprit. So I guess I have to clean up a bit, and we’ll get this up and running again :upside_down_face:


Broken data (component tree) could absolutely be a reason to these errors as well.