Enable zip64 extension


#1

Enonic version: 6.15.7
OS: Ubuntu

Has anyone come across this error?

How do we enable zip64 extension in build.gradle?

Thanks!


#2

archive contains more than 65535 entries.

It sounds very unusual that you should need to allow for more than 65535 files or 4GB bundled into your application JAR file. Are you sure about this? Do you have a ridiculous amount of assets or configuration files inside your app resources? A more typical file count is somewhere between a few hundred to maybe a few thousand. My most complicated apps have no more than 500 files inside the /src folder, but I’ve seen a few very large and old sites that were converted from Enonic CMS to XP that have had around 5000 files.

I’m guessing that those settings are set inside the com.enonic.xp.app plugin which is likely listed at the top of your build.gradle file. Pehaps you can override it by writing some lines of code in build.gradle, I don’t know. But in the gradle documentation, that setting is marked as “incubating”, which means that you should perhaps only use it if you really have to.

If I were to get an error like that, I would suspect that my system had generated too many temporary garbage files inside my working directory, by accident. Or that something in the build process is running in an infinite loop that keeps generating more and more files.


#3

@bhj

Yeap. I had to clean my asset folder a bit.

I had over +65535 files in it.

It is fine now.

Thanks!


#4