Endless loading in a Content Studio

Enonic version: 6.9.0
OS: Elementary Loki (Ubuntu 16.04)

Hello, we are currently facing an issue with an endless loading after a removal of content in a Content studio. There are no errors in console. Also, we are using a regular content selector and a custom selector. Both of them used removed content.


1 Like


We need to know a bit more about how and where you get the endless spinner. This will help us to locate and fix the problem faster. Can you describe the entire sequence of steps, please?

Hello, Alan

This happens in a Content studio while editing a content type. There are no errors in a console and no errors or something in a front end. Just an endless spinner with no possibility to edit a content type via Content studio.

We have also a content selector with a service, where some other content types were assigned. I presume that this could happen after removing content object that assigned content types without removing a relation.


Here’s what I tried now:

  1. Create a new image selector content
  2. Upload some new images into the selector
  3. Save content
  4. Close content
  5. Delete the images that were uploaded
  6. Reopen the content

Selector was highlighted with red background and I got warnings about images not found, but nothing froze and there was no endless spinner.
Then I tried the same with “Custom Relationship” content type - added references to child content items and then deleted them. I was still able to open the parent content (again, with highlighted selectors and warnings).

Isn’t that about the same as what you described?

It seems to work fine with built-in content types in XP, so maybe you are using a content type that you made yourself? In that case, can you send us your content schema(s) and provide a bit more info about how you got the error?

Hello Alan

I’ve found the issue and it wasn’t related to content/custom selector. It’s the “AttachmentUploader”. Here is a part of content type that breaks everything:

<item-set name="ATTACHMENTS">
      <input type="TextLine" name="ATTACHMENTS_TITLE">
        <occurrences minimum="1" maximum="1"/>
      <input type="AttachmentUploader" name="ATTACHMENTS_URL">
        <occurrences minimum="1" maximum="1"/>
  <occurrences minimum="0" maximum="3"/>

Steps to reproduce:

  1. Add title and upload a file
  2. Save and publish
  3. (optional, worked for me without this) Remove a file
  4. Open for editing. Endless spinner should appear.




Sorry for delayed response. We confirmed the bug and created an issue to fix it in the upcoming version of XP. You can check the status here: https://github.com/enonic/xp/issues/4753

Hello, Alan

thanks! :slight_smile:

This bug was fixed, and the fix included in the 6.10.0 release, which came on April 24th.
(Please notice that 6.10.1 came two days later with an important bugfix for long running servers, so we recommend using it.)