Has anyone gotten core-js to work server-side?

Enonic version: 6.8.0
OS: Linux

Trying to import/require core-js modules the default way gives me the following error:

TypeError: Cannot set property "core" of null

Using without global namespace pollution gives the following error:

TypeError: Cannot get property "__core-js_shared__" of null

Neither Nashhorn, purpleJS or Enonic XP is listed among tested engines here:

Has anyone been able to use core-js server-side on XP?

Or perhaps someone knows why it fails?

Note: Specificly I’m trying to use Symbol. (I’ll go looking for ponyfills now)

As a side note here’s why:

I’d like to use Symbols to make private methods like here:

https://www.npmjs.com/package/es6-symbol fails in similar manner:

TypeError: null has no such function "call"

I’ve tried these variants:

import Symbol from 'es6-symbol';
import { Symbol } from 'es6-symbol';
var Symbol = require('es6-symbol/polyfill');

Hmm this could be something:

Just mentioning the section of an article that got me thinking:

“Wait, you tried to run my code where?”