Inspect -> Parts is broken

Enonic version: 6.4.2
OS: Windows 8, Ubuntu

There a lot of parts are available and a lot pages with these parts.
After content import (without errors), I cannot select part. Maybe this content issue, but I’m not sure, because there is no issues during import

Any thoughts ?


This looks like it could because of a malformed part.

Click open the dropdown again. Does anything new come out in the XP server log?

If not, also open any console or developer tool in your browser and check the Javascript logs in there. What do they say?

There no issue or warnings in console and enonic log.

How to enable max log level at enonic ?

Where did you get the import from? If you exported from 6.3.0 and try to import that into 6.4.2 then it might not work. Check the documentation here

Also, check the Applications tool and see if any parts are registered in the app. If not, try to uninstall and reinstall the app and maybe do a gradle clean build of the app code.

I’ve already done a lof of tests, but it still not working.
Original export was at 6.3.0.

Tried to import at 6.4.2 - parts are not working.
Also I’ve tried to do import at 6.3.0 no luck too.

Applications -> My app -> Descriptors -> Part -> all parts are here (But not in dropdown menu)

Follow the instructions on the 6.4 upgrade documentation page. Basically, go back to 6.3.1 (NOT 6.3.0) and use the toolbox to dump the content from there. Then delete all content and stop the server. Then run 6.4.2 upgrade tool on the dumped content and then start the 6.4.2 installation. Let us know if that doesn’t work out.

Have the same situation like “wox” have. Copied content from 6.3.0-m2 manualy(by copying /deploy and /repo folders) to 6.3.1 and gone throught all upgrade process(exported data to dump, upgraded it and loaded into 6.4.2). All processes gone without errors but I have got not usable content in the end. Almost all pages give the very same errors Application was not found (

And even I have got all the pages that was in Enonic in previous version like a content, all the icons shows that them are broken, and I can’t create any additional content, since I can’t see all my parts and pages in “New” dialog, only standart one’s.

Can one of you go into the Application admin tool, select the app, and take a screenshot of it like Michael suggests? It would be interesting to see if the parts and pages are at all registered.

As Michael also mentioned, the toolbox in 6.3.0 is broken, so an export from it will not work (and would behave a lot like this). But if you used 6.3.1 toolbox then this must be because of something else.

I have managed to found that erro “Application was not found (” was because I have not placed *.jar file in /deploy folder. But now I do, and get the very same behaviour on 6.4.2

Screnshoot of admin panel, seem all the parts are visible in it.

Try stopping then starting the app. Go back to Content Studio, do a “hard reload” (without caching) and check the Part-selector again. This really sounds like some odd cache in some browser. Using Firefox?

No deal, we are using Chrome, and it’s reproducing on all out machines, seems to be it somehow conected with content.

As Michael also mentioned, the toolbox in 6.3.0 is broken, so an export from it will not work (and would behave a lot like this). But if you used 6.3.1 toolbox then this must be because of something else.

IMHO, its looks like not export/import issue.

Because my original installation is 6.3.0.
I dont do any import here. All content has been added via content manager.
And issue occurs at 6.3.0 (Once again all content has been added via content manager.)

Tested with different browsers.
When I’m to do export from 6.3.0 and then import as you has described I’ve faced with same issue. So, its, probably, may be, issue (code issue) with part selection for Part Drop down .

Are you sure the name of the application didn’t change between the export and import? Make sure the name of the app in the Applications tool matches the name in the 404 error page. It should look something like but it’s blanked out in the screenshot. Make sure the app jar file is in the $XP_HOME/deploy folder.

Do not export or dump from 6.3.0. Also, for 6.4.2, remove the config file $XP_HOME/config/org.apache.felix.fileinstall-deploy.cfg

Export in 6.3.0 is broken and will not load content properly. It shouldn’t affect parts. Only errors in the part controller could should be able to produce this type of error … however that should only “skip” that particular part, log it, and then show the rest.

Bug was inside of *.xml file like you have said. The reason of the bug was smth like

Good you found it =)

Can you send me this xml so I can reproduce the error? We want to capture this and give a good error message in the log. You can send it privately to me too.

There was a part without “display-name” tag.

Impressive =)

Good you found out what it was. We will try and handle errors like this in the future by disabling the broken part and adding log messages.