Issue in using simple Id provider


#1

Enonic version: 6.12.2
OS: Linux

There is problem while using simple Id provider for authentication.

vhost mapping is :
mapping.www-xyz-se-extranet.host = www.xyz.se
mapping.www-xyz-se-extranet.source = /extranat
mapping.www-xyz-se-extranet.target = /portal/master/xyz-se-extranet
mapping.www-xyz-se-extranet.userStore = extranetuser

As it seems, the base url for this site will be “www.xyz.se/extranat”

But while we do logout, or Forgot password url gets changed each time to “www.xyz.se/” . ( with some _/idprovider/… after that). And then it stops working.

Note: “www.xyz.se” and “www.xyz.se/extranat” there are two different sites we have.


#2

I tried to reproduce your situation (I did it on the latest Enonic XP though, I will try with a 6.12.2 later) but still have the correct URLs.

So if I understand correctly:

  1. You go to www.xyz.se/extranat
  2. The site “xyz-se-extranet” is forbidden so the login page is displayed
  3. You click on “Forgot your password?”, enter the mail and click “Reset”

But so what is wrong now?

  • Is it the link received in the mail that is wrong?
    Is this link www.xyz.se/extranat//idprovider/… or www.xyz.se//idprovider/… ?
  • Or is it when you update the new password
    Do you then get redirected to www.xyz.se/extranat//idprovider/… or www.xyz.se//idprovider/…
  • Or is it now that you are now logged in and you click on “LOG OUT”?
    Do you then get redirected to www.xyz.se/extranat//idprovider/… or www.xyz.se//idprovider/…

#3

Yes, your understanding is correct.

Reply to question 1: The link received in the mail is correct. its “www.xyz.se/extranat/_/idprovider/”

Reply to question 2: When I submitted the “Password reset” form with the email id, it is redirected to “xyz.se/extranat/_/idprovider/utviklingsstore?action=sent” and I am unable to login anymore. If I try logging in, I will be redirected to “www.xyz.se” which is wrong.

Another error:
Once we have received the email to change our password, we get a correct link to rest the password. when we submit the form with new password we get “Logout” button. When we click on that, we are redirected to “xyz.se/extranat/_/idprovider/utviklingsstore/logout”. We are unable to login after that.

Reply to question 3:
When we use “logoutUrl” to create a link and logout the user, from web page it does not work. Once we are logged out it will route us to “xyz.se/_/idprovider/” which won’t work.
( We have sixed it though using “logout” method in a service and calling that instead of logouturl. But would be nice to get the same fixed in id provider.


#4

I understand the problem now.
The problem happens on redirection from already opened tabs, after having logged in/out, and when the site is forbidden

I will create an issue about this. Thank you for reporting the problem. :+1:


#5

Not sure, but is it something which can be fixed soon?

We have a production issue, and would it need soon.

Thanks


#6

It is now solved in the version 1.2.1 of Simple ID Provider.
But it required a bug fix of a 6.13 Enonic XP library.

So you will have to upgrade to Enonic XP 6.13.1 to use this new version


#7

Thanks a lot. It did work after the upgrade.


#8