Issue when working with the ComboBox

Enonic version: 6.7.3


#1 If I enter a valid value, and use tab to move on in the form it doesn’t select the value.
Note: Using arrow down, enter and then double tab to move to next field doesnt feel quite right.

#2 The validation with occurrences doesn’t work, perhaps due to it being in a item-set?

#3 It doesn’t jump to next input when pressing “tab”, just to the arrow, perhaps by design, but it differs from my expected pattern. But perhaps I’m still missing a the native dropdown

Hmm… sounds like things are a bit buggy to me. Anyway, to confirm a value you must press enter. Pressing enter should move you to the next input.

Can you confirm if #1 doubletab + #2 and #3 only happens inside an itemSet?

I can confirm that all :three: cases occurs :evergreen_tree: outside of item-sets.
Note: In my testcase I’m using it in a Part.

It would be a nice improvement if it worked pressing enter to confirm a value without the need to use arrow keys to “select” item, at least if it only are :one: result that matches the search :mag:

But as you mention, it jumps to next field if I use arrow down and hit enter, but just using arrow down to select proper value and then tab on it just jump to the “arrow”.

Ah… jup, currently validation does not apply in parts - we need a way to handle this in UI so users can understand what’s wrong. Use enter to select and you get what you’re looking for. Since we really want the user to confirm his selections. We’ve worked quite a lot to make this work properly using keyboard only, but I guess we could test this even more.

Any update on validation of parts?

Maybe it will get prioritised if I tag it with PWA :wink: … but my opinion is that validation should work anyway, especially since the feature is there both in schema and partially in GUI.

1 Like

Hi Edwards,

This is prioritized for Q3 2017. We suggest you add handling in your controllers to make sure this doesn’t break anything.


1 Like