Mismatch between usergroup memberships in view and in the userstore

Enonic version: 6.7.3
OS: Ubuntu

I have migrated user and usergroups fra Enonic CMS to Enonic XP. This worked fine.
But when I view a user in the Users APP. It does not display all usergroups for a user. Only 10 usergroups is displayed but the user has about 20.

See screenshot for what you see in UI and what the server prints.

1 Like

It also seems that a user can only be added to a MAX of 9 usergroups.

This is a bug in admin. Thanks for reporting it, it wasn’t a known issue. I’ve registered it for fixing. Maybe it can be included in 6.8.

I could not reproduce the other problem. You cannot add a user to more than 9 groups?
I have added a user to 12 groups, from Users in admin, and seems to be ok. The only issue is what you mentioned, they do not all show in the preview when you select the user. But if I edit it, the users are selected in the combobox.

1 Like

Ignore my last comment. The number of groups is also limited in the combobox. We will fix it.

1 Like

Alex has fixed it, and it will be included in 6.8.0, to be releaed toward the end of this week, or early next week.