No tests found for Java nor JS


#1

Enonic version: 7.2.1
OS: Windows 10

I’ve written some tests for Enonic XP controllers and Java code in a XP project. Everything has worked up until now.

In my dependencies I have/have had these dependencies:

So after trying to get things to work, I’ve tried deleting all the tests to see if there was en error with the dependencies or the tests themselves. I set up a new test case for a controller which only asserts true with a package layout like this:

image

package controller;

import com.enonic.xp.testing.ScriptRunnerSupport;

public class StartControllerTest extends ScriptRunnerSupport {
    @Override
    public String getScriptTestFile() {
        return "/controller/ControllerTest.js";
    }
}

And in the JS-test:
var t = require(’/lib/xp/testing’);

exports.testParam = function () {
    t.assertEquals(true, true);
};

What have I done wrong? I’ve tried to invalidate chaches and restart IntelliJ, deleted different dependencies, deletes .gradle and deleting the entire project and clone it off of the repo again.


#2

First, did you try using 7.2.4?


#3

After rebasing at a previous commit, where the tests worked, everything seemed to work out like it should. There were no significant changes that would affect dependencies from those commits. Don’t know if it was a gradle issue or not.

Thanks for the answer! Will try to update to the newer release as well!