Port 8080 occupied

Enonic version: 1.3.0
OS: Linux

Hello.

I am trying to get Enonic XP up and running on port 9000. Initial problem is that XP_HOME is set to /srv/enonic but is seems not to acknowledge that /srv/enonic/config and contains files:

[email protected]:/srv/enonic# ./enonic sandbox start
Port 8080 is not available, stop the app using it first!

[email protected]:/srv/enonic/config# ls -al
total 12
drwxrwxr-x 2 www-data www-data 4096 Jul 17 15:21 .
drwxrwxr-x 5 www-data www-data 4096 Jul 17 15:17 …
-rw-rw-r-- 1 www-data www-data 603 Jul 17 14:50 com.enonic.xp.web.jetty.cfg
-rw-rw-r-- 1 www-data www-data 0 Jul 17 15:21 system.properties

[email protected]:/srv/enonic/config# more com.enonic.xp.web.jetty.cfg
host =
sendServerHeader = false

Connection

timeout = 60000

HTTP settings

http.enabled = true
http.port = 9000
http.requestHeaderSize = 32768
http.responseHeaderSize = 32768

Session

session.timeout = 60
session.cookieName = JSESSIONID

Compression

gzip.enabled = true
gzip.minSize = 23

Logging

log.enabled = true
log.file = ${xp.home}/logs/jetty-yyyy_mm_dd.request.log
log.append = true
log.extended = true
log.timeZone = GMT
log.retainDays = 31

Thread Pool

threadPool.maxThreads = 200
threadPool.minThreads = 8
threadPool.idleTimeout = 60000

Websocket

websocket.idleTimeout = 300000

Any ideas anyone?

Best regards, Atle

Hi @Nesrene !

CLI is designed to work with different versions of Enonic XP and it can not rely on certain file structure of format.Therefore it communicates with Enonic XP through http requests and does not read its config files currently, so it assumes default port 8080.

If you absolutely need to have Enonic XP running on port 9000, you could try port forwarding 8080 -> 9000 for CLI.

But that is a very good point and we will consider adding it to future releases of CLI !

1 Like