Problem with re-deploying app locally

Enonic version: 6.4.1

I’m having some problems re-deploying the application (via gradle deploy and gradle deploy -t). When it’s being redeployed, I get the following error:

16:18:04.412 INFO - Application [] installed successfully
16:18:07.269 WARN  org.apache.felix.fileinstall - Failed to update bundle: /path/to/xp-home/deploy/website-1.0.0-SNAPSHOT.jar with ID 58. The bundle has been uninstalled

I’ve tried to delete the apps in the $XP_HOME/deploy file and that seems to work. However, once I re-deploy it again, the error returns.

I’ve tried to install it via the new install app functionality, and again, it works at first, but then, on redeploy - it fails.

When I restart the server, it works, but gives me this log:

19:40:10.911 WARN  org.apache.felix.fileinstall - A bundle with the same symbolic name ( and version (1.0.0.SNAPSHOT) is already installed.  Updating this bundle instead.
19:40:11.100 INFO  org.apache.felix.fileinstall - Started bundle:
19:40:11.101 INFO  org.apache.felix.fileinstall - Started bundle:

When I redeploy - it gives the same error as above.

Any idea on what I’ve done wrong?

EDIT: It actually looks like its updating the jar - it’s just a bad error message. Still, I would like to know what’s gone wrong here.

Did you remove the felix fileinstall config from your config/ directory as specified in the 6.4 upgrade?


The config/ folder looks like this:

$ cd $XP_HOME/config/
/project-home/config $ ls
total 48
drwxr-xr-x@ 9 selbekk  1333597109  306 Feb 25 09:51 .
drwxr-xr-x@ 8 selbekk  1333597109  272 Feb 25 09:50 ..
-rw-r--r--@ 1 selbekk  1333597109    0 Feb 25 09:50 README.txt
-rw-r--r--@ 1 selbekk  1333597109  421 Feb 25 09:50 com.enonic.xp.elasticsearch.cfg
-rw-r--r--@ 1 selbekk  1333597109  108 Feb 25 09:50 com.enonic.xp.mail.cfg
-rw-r--r--@ 1 selbekk  1333597109  222 Feb 25 09:50 com.enonic.xp.web.vhost.cfg
-rw-r--r--@ 1 selbekk  1333597109  833 Feb 25 09:50 logback.xml
-rw-r--r--@ 1 selbekk  1333597109  430 Feb 25 09:50 org.ops4j.pax.web.cfg
-rw-r--r--@ 1 selbekk  1333597109  334 Feb 25 09:50

Today it seems to be working perfectly. It might have been a totally unrelated problem, perhaps something to do with some apps that were no longer installed :smile:

I’ve been seeing some similar issues. Especially when bumping version numbers, or after upgrade. It’s like XP has a hidden jar in that folder that it complains about. I have seen this exact issue too.

We’ve noted down some scenarios around this that I’ve added to our internal bug tracker. Things work, but with some hickups sometimes.

@selbekk If you have these logs after the restart of your server, it means that the server still sees the file “org.apache.felix.fileinstall-deploy.cfg”. Are you sure the XP home location used was the correct one and that the file was deleted at this location?
To be sure, at the beginning of the logs, you can see a line “# Home directory is /Users/gri/Workspace/home”.