Problems with React4xp enonic project deploy

Enonic version: 7.8.4

Enonic CLI version 2.3.0
OS: Windows 10 Pro


I am relatively new to Enonic, I’m having some problems with the react4xp application deployment. I create a project using the “enonic project create -r starter-react4xp” but when I execute the command “enonic project deploy” to run the project the error happens. Can you please help me with this?

Thank you in advance

PS D:\Enonic Projects\myfirstapp> npm version
‘starter-react4xp’: ‘2.1.0’,
npm: ‘6.14.8’,
ares: ‘1.16.1’,
brotli: ‘1.0.9’,
cldr: ‘37.0’,
icu: ‘67.1’,
llhttp: ‘2.1.3’,
modules: ‘83’,
napi: ‘7’,
nghttp2: ‘1.41.0’,
node: ‘14.15.1’,
openssl: ‘1.1.1g’,
tz: ‘2020a’,
unicode: ‘13.0’,
uv: ‘1.40.0’,
v8: ‘8.4.371.19-node.17’,
zlib: ‘1.2.11’
PS D:\Enonic Projects\myfirstapp>

It seems like you have created your project on a day when we made some changes to our starter which could cause this behaviour. I’ve just created a new project based on React4XP starter and enonic project deploy works for me without any errors. Can you try recreating your project?

Yes of course, why not? I tried create a new project but unfortunately it has the same problems.

Hey Mehdi,

The folder name with a space is breaking the build.
Could you rename “/enonic projects/” to enonic_projects ?


Hello sir,
I changed my folder name to Enonic_React and then made a new project. After that I run “enonic project deploy” fortunately it’s working.

I appreciate you.

1 Like