Request to Launcher is slow in dev mode

Enonic version: 6.7.3

When running the server in dev mode, the initial “application list” and “creating content” dialogs are incredibly slow.

Missing the application menu to the right… comes after 1.5 min waiting

the same when creating a content… loading spins 1min +

For me it seems like it’s the request to the launcher at
that seems to be waiting forever… even though the reality it is only 1-2 minutes waiting… the server doesnt log any errors.

If it where just once, there wouldn’t be a big issue but since the request to the launcher is also performed whenever you create a content, there is the same wait there.

For now I’m running Enonic without the dev flag and using the continious build feature with Gradle.

Thanks for reporting. I will see how we can improve this. The goal is that it should not be visually slower than the production environment.

Do you have a lot of content types, parts and pages?

Not really… would call it a very basic site.

Do you also suffer from a serious performance hit here?

When @espen_haviken is running it there isn’t any real problem. He is running on windows though and I starting to wonder if there is some config issues here on my macbook…
Since I still get this slow performance on that one request even on “blank” projekts.

I believe Edward even tried to install a fresh Enonic XP install without any apps deployed, and the “main menu” was still very slow, over a 1 minute to respond.

@srs Can this be related to that issue with users that run XP on latest OSX (Sierra)?

When running with yourkit; this method seems to go on for ever when running in dev-mode on my machine:

Im on Sierra.

We have identified the problem and will fix it in 6.8. 6.8 RC2 will be released pretty soon with the fix.


6.8.0 was released last week with a fix for this problem. See XP-4483 here: