"Show all help texts" not opening all texts

Enonic version: 7.8.1 (same in earlier versions)
CS version: 4.0.0 (same in earlier versions)

When editing content types in CS there is a “(?)” icon on the ‘bar’ that reads “Show help texts”.

I’d assume it would open every help text that is present on the content type that I’m currently editing, but it’s just hitting the ‘most basic’ ones.

Basic stuff like built-in or inputs that are directly defined on the < form >: opens help-texts as expected.

But the moment the inputs are inside e.g. a field-set (any set I believe) then help texts are not opened. Same with x-data and mixins.




I don’t think I have a mixin/x-data that doesn’t wrap its inputs in a set, so I think we can assume the issue lies with sets rather than things being x-data/mixins.

TLDR: “Show all help texts” doesn’t show all help texts.

Hello, Jonas! Thank you for reporting this, we’ve already created a task to solve this problem, so it will be fixed in the next release

Hey, I tried the new release of CS (4.0.2) where this is ‘fixed’, but it still doesn’t open all help-texts:

From what I can see the help-texts within the sets are now showing, but not the help-text for the sets themselves :slight_smile:

Hi, @JonasR, could you please provide your content type config so we could test directly your case? Thank you!

The content type is rather large /w multiple mixins, so here’s a smaller version of it:

    <display-name>Testing help texts</display-name>
        <input name="ingress" type="TextArea">
            <help-text>Help text 1</help-text>
            <occurrences minimum="1" maximum="1"/>
        <option-set name="middle_block_selector">
            <label>Midt-blokk innhold</label>
            <occurrences minimum="1" maximum="1"/>
            <help-text>Help text 2"</help-text>
            <options minimum="1" maximum="1">
                <option name="opt_test_opt1">
                    <label>Kampanje blokk</label>
                        <!-- <mixin name="campaign-block" /> -->
                        <input name="mixin-replacement-for-test" type="TextArea">
                            <label>Ingress test</label>
                            <help-text>Help-text 3</help-text>
                            <occurrences minimum="1" maximum="1"/>
                <option name="opt_test_opt2">
                    <label>Test opt 2</label>
                        <input name="ingress2" type="TextArea">
                            <help-text>Help-text 4</help-text>
                            <occurrences minimum="1" maximum="1"/>

This looks like this:

1 Like

Hello, @JonasR, fixed it, will be available in the next release! Thank you for reporting this


@JonasR This should now be fixed in the latest Content Studio 4.0.3 (requires XP 7.8.2 or higher).