[SOLVED] Tool not showing in Apps menu


#1

I created a new tool based on admin tool starter, and it works perfectly.
I added its .jar though the Applications menu, but it doesn’t appear there only in the admin main panel.


#2

The first thing to check is if xpVersion in gradle.properties matches your version of XP. Are you saying you can see it in your Launcher panel but not in the list of applications?


#3

How did you build it?
Using gradle and the plugin “com.enonic.xp.app” (https://github.com/enonic/starter-vanilla/blob/master/build.gradle)?


#4

Yes, i can see it in my Launcher and not in the list of apps.
About the version, the starter is 7.0.0 and my XP is 7.2.0. I changed the version on gradle.properties and ran again with enonic project build but it didn’t work.


#5

I ran enonic project build and uploaded the .jar generated in libs folder.
And yes, i’m using id 'com.enonic.xp.app' version '2.0.0' lib.


#6

Did you deploy the app? If you are building locally with CLI then you should deploy via “enonic project deploy” instead of uploading JAR via Applications module.


#7

Yeah, i tried both. With deploy it should also appear in the list, right ?


#8

Yes, definitely. There should be a message in the XP log after successful deployment of the app, like “Application … started successfully” - did you get that?


#9

Yeap

2020-02-25 12:33:59,612 INFO c.e.x.c.i.app.ApplicationServiceImpl - Local application [com.acme.starter.admintool] installed successfully
2020-02-25 12:33:59,614 INFO c.e.x.c.i.app.ApplicationServiceImpl - Application [com.acme.starter.admintool] started successfully


#10

Can you tell us a bit more about how you created the project? Did you select “Custom repo” when you created the project with CLI and specified Admin Tool starter repo?


#15

I created the tool with the “Admin Tool Starter”, but something seems wrong with this project.
I created another with the Vanilla Starter and XP version 7.0.0 (the serve’s 7.1.0) and it worked.