Source action is not available in HtmlArea when placed inside item-set


#1

Enonic version: 7.2.0
OS: MacOS Mojave 10.14.6
Content Studio: 2.3.1

Hi guys! I want our editors to be able to use the source-code button/action inside the HtmlArea, however it seems like the action-button is missing when I put the HtmlArea inside an item-set (I have tried to maximize the input-field) . When used without an item-set it works as intended. We are heavily involved with react4xp in our project if that is relevant. Possible bug? Or have I missed out on some important docs :grimacing: Thanks!


#2

Is your HTML Area inside a content type or inside a part config?

I’ve tried putting HTML Area inside an item-set in a content type and source code button is there for me. Can you share your XML schema?


#3

Hi, ase! Thanks for your reply :slight_smile:

I am using it inside a part config.

<part>
    <display-name>Team contact</display-name>
    <description>Team contact</description>
    <form>
        <input name="teamContactTitle" type="TextLine">
            <label>Title</label>
            <occurrences minimum="1" maximum="1"/>
            <default>Team contact title</default>
        </input>

        <input name="preface" type="HtmlArea">
            <label>Text</label>
            <occurrences minimum="1" maximum="1"/>
            <default>This is giving me a Source option</default>
            <config>
                <!-- <exclude>*</exclude>
                <include>AlignLeft AlignRight | Bold Italic</include> -->
            </config>
        </input>

        <item-set name="columns">
            <label>New team member</label>
            <help-text>Use this to add multiple team member's</help-text>
            <occurrences minimum="1" maximum="0"/>
            <items>

                <input name="contactName" type="TextLine">
                    <label>Name</label>
                    <occurrences minimum="1" maximum="1"/>
                    <default>Team member name</default>
                </input>

                <input name="aboutContact" type="HtmlArea">
                    <label>This is not giving me a Source option</label>
                    <occurrences minimum="1" maximum="1"/>
                    <default>[email protected]</default>
                </input>

                <mixin name="image"></mixin>
            </items>

        </item-set>
    </form>
</part>

#4

We have reproduced the bug and registered it here. Will be fixed in the next hotfix release of Content Studio early next month.


#5

Perfect!
Thank you :smile:


#6

The fix is available in Content Studio 2.3.2


#7