Test plugin do not fail tests that should fail after v 7.7.4

Enonic version: 7.8.3 (but also tested with 7.8.4)
OS: Mac


We use your “Testing” plugin (Testing Applications and Libraries - Enonic Developer Portal), but found that tests that should have failed do not fail anymore. I tested reverting the Enonic version we were sure worked correctly with our tests, and as expected the tests that should fail failed again. So, with the same tests, we get correct behavior with version 7.7.4, but not with 7.8.3 or 7.8.4.

For now, I use the plugin by including it in my gradle dependencies with:

include "com.enonic.xp:testing:7.7.4"

Before, we included it with

include "com.enonic.xp:testing:${xpVersion}"

but this will not work as long as we use 7.8.3 :slight_smile:

Could you try XP 7.9.0 RC1? I think the issue is fixed there.

Yes, I tried to update to using

xpVersion = 7.9.0-RC1

and in gradle using

include "com.enonic.xp:testing:${xpVersion}"

And then it works as expected again, and the tests that should fail fails :slight_smile:

7.9.0 has now been released

1 Like