Tsup Starter has arrived!

We are happy to announce a new add-on to the family of Enonic Starters!

New Tsup Starter is designed to showcase capabilities of Enonic XP platform (APIs, admin extensions, asset handling, sample CMS components etc.) and enable Typescript developers to get their code quickly transpiled and bundled. On top of that, the Starter comes with built-in support for hot reload which means that changes done in either server- or client-side code can be displayed real-time, without developers having to rebuild the app or even refresh the browser window.

Please read the guide to understand what’s included in the Starter, ask us questions and suggest your improvements!


In the documentation (Tsup Starter - Enonic Developer Portal) we have the following:

2.In another terminal window run your project in the dev mode:

enonic project dev

This argument doesn’t exist for enonic project command. Something may be lacking in this snippet.

1 Like

Thanks for pointing this out!

This command will be added to CLI very soon, so we went a bit ahead of ourselves in the guide. For now please use “project gradle dev”.

We’ve updated the guide.

1 Like

HI @ase ,

looks great so far, but unfortunately I get the following errors whent trying to deploy the project:

[server] npm run build:server started at 2023-09-19 14:07:33.234
[server] Cannot find src\main\resources\main.ts,src\main\resources\index.d.ts,src\main\resources\constants.ts,src\main\resources\webapp\webapp.ts,src\main\resources\types\Response.d.ts,src\main\resources\types\Request.d.ts,src\main\resources\types\PageContributions.d.ts,src\main\resources\types\index.d.ts,src\main\resources\types\ContentSecurityPolicy.d.ts,src\main\resources\tasks\task\task.ts,src\main\resour


[static] Error: UNKNOWN: unknown error, open 'D:\Developement\enonic\tsup\build\resources\main\static\src\main\resources\static\react\App-LSMLL6NK.css'


[static] npm run build:static exited with code 1
--> Timings:
--> Γöé name   Γöé duration Γöé exit code Γöé killed Γöé command              Γöé
--> Γöé static Γöé 7.550    Γöé 1         Γöé false  Γöé npm run build:static Γöé
--> Γöé asset  Γöé 6.145    Γöé 1         Γöé false  Γöé npm run build:asset  Γöé
--> Γöé server Γöé 6.139    Γöé 1         Γöé false  Γöé npm run build:server Γöé
--> Γöé sass   Γöé 5.731    Γöé 0         Γöé false  Γöé npm run build:sass   Γöé

> Task :npmBuild FAILED

You’re on Windows, right? We have discovered the same error earlier today and hope to release a fix today/tomorrow.

Yes I tried on Windows - but also have a MAC :slight_smile:

Hmm, are you getting the same errors on Mac as well?

I did not test it on MAC yet :slight_smile: