Unable to boot enonic XP on macOS


#1

Enonic version: 6.15.5
OS: macOS High Sierra

Enonic XP refuses to start except if I run it as root. The error message I get is:
ERROR: Unable to create cache directory: /home/xxx.xxx/enonic-server/enonic-xp-6.15.5/home/work/osgi/cache
ERROR: Error creating bundle cache. (java.lang.RuntimeException: Unable to create cache directory.)
java.lang.RuntimeException: Unable to create cache directory.

I have tried setting all the files in file rights to 777 without any luck. What am I doing wrong? All I did was download the latest version of XP, set the XP_HOME environment variable and run it.


#2

I had the same issue.
It cant seem to find its cache folder for some reason.

I tryed running the server from its home dir so:

from: /../home/my_xp_home/
Run the absolute path to xp server eg. C:/xp_server_folder/enonic-xp-6.15.5/bin/server

With this workaround the server was running again.

After this i would set XP_HOME environment variable again.
I just set it to " " and then back to my home dir again.

Now it seems to run again without any issue.

My guess is that it cached its home folder, and it expects that folder or crashes without.


#3

Ok! Thanks for the reply. I am setting up XP using docker to avoid this problem for now.


#4

The problem was my own fault. I had an error in the path for the XP_HOME environment variable.


#5

This topic was automatically closed after 5 hours. New replies are no longer allowed.