Unable to import/export content in datatoolbox


#1

Enonic version: 6.15.2 or any latest download from Enonic
OS: MAC OS High Sierra

Option for uploading /downloading is missing in latest downloads. I tried in 6.14.3 or 6.15.2


#2

1 - What is the version of Data Toolbox that you are using?
2 - What are the roles of your user (You can go to “/admin/rest/auth/authenticated”) ?

Because this could happen, on purpose, if you are using a version of DT < 2.1.3 and if your user does not have an admin role. (Starting from 2.1.3, the DT widget is not listed if you are missing the admin role).

If this is not the case, then could you also specify if you see any error
in the browser console
in your server logs
And also what browser you are using.


#3

I am using Chrome and DT version is 2.2.1

I tried to import using backend command. I didn’t see any error in logs and was able to see my export folder in node exports. However, the contents were not available in the content studio and the folder was empty.


#4

But do you see any errors in your Chrome’s dev tools console (Alt-Cmd-I, then switch to “Console” tab)? It looks like there’s something wrong with rendering of the widget itself since the panel is completely blank. In this case there should be errors in the browser console.


#5

You are right. Thank you for reporting the problem.

A gradle plugin used to generate the widget has failed during the build of the released version 2.2.1
This problem seems to have only happened for this specific build (other 2.2.1 beta versions were correctly generated and versions built since are also correct).
I will be more vigilant in the future.

Meanwhile, there has been other versions (2.2.2 and 2.2.3) released.
I recommend to update to one of these versions